Upgrading to WordPress 5.x

Category: FAQ | Last modified: August 20, 2020

WordPress 5.x and the new Gutenberg editor have arrived to Pressable! Now, all Pressable customers have the option to upgrade their sites to WordPress 5.x.

Upgrading to 5.x is easy! Just navigate to https://my.pressable.com, locate your site, click “Settings”, and then click “Upgrade to WordPress 5.0” at the top of site page in MyPressable.

Not ready yet? No problem! You don’t have to upgrade at this time. However, we strongly recommend that you start preparing your sites for 5.x because on February 20, 2019, all Pressable sites will be upgraded to 5.x.

To get your sites ready for 5.x, we suggest upgrading on a site-by-site basis and making use of the cloning functionality in MyPressable Control Panel. Sites will clone version-to-version. In other words, a clone of any site will come with WordPress 4.9.9 installed. When you’re ready to upgrade the clone, you may do so from MyPressable Control Panel.

If you do not have any sites available in your account, submit a support ticket requesting the sites to be cloned, and we’ll be happy to create them for you, free of charge.

An upgraded clone will allow you to test your production site’s functionality on 5.x. If there are issues with a plugin or a theme, then you can check with the developer and see if there is an update for 5.x. If there is not an update available, you’ll want to activate the Classic Editor plugin, which will automatically be installed on all sites with 5.x. If activating the Classic Editor plugin does not fix the problem, the Pressable Customer Success team will be happy to take a look at the issue and offer advice on what to do next.

We are very excited about WordPress 5.x, and we can’t wait to see what you will build with it! If you have any questions or concerns, please submit a support ticket or initiate a chat with us from MyPressable Control Panel.


WordPress 5.x Frequently Asked Questions

Is WordPress 5.x available on Pressable?

Yes, you can make the upgrade for each of your sites, whenever you’re ready.

Do I have to upgrade my sites to 5.x?

No, you do not have to upgrade to 5.x at this time. However, we recommend that you start getting your sites 5.x ready as soon as possible because any site that isn’t running on 5.x will be upgraded on February 20, 2019.

How can I make sure my site is ready for WordPress 5.x?

First, make use of MyPressable Control Panel’s cloning functionality to make a copy of your site for testing purposes; clones will clone version-to version. Once you have a clone of your site, you can upgrade it to 5.x and see how it performs.

If you do not have any available sites in your account for clones or if you run into any errors getting your sites 5.x ready, submit a ticket, and the Pressable Customer Success Team will be happy to help.

What if my site has a 500 error when I upgrade to WordPress 5.x?

If your site has issues after upgrading to 5.x, we recommend activating the Classic Editor plugin, which will be installed on all Pressable sites with 5.x.

If that doesn’t resolve the issue, please contact the Pressable Customer Success Team for further assistance.

An Automattic Invention A family of WordPress solutions.