Disallowed Plugins on Pressable

Category: FAQ | Last modified: August 17, 2020

There are quite a few plugins in the WordPress ecosystem; WordPress.org has over 27,000 just in their repository. However, from time to time we run across plugins that don’t play well on our systems, or duplicate functionality we’re already providing as part of our managed services. As such, we’ve added functionality to prevent these plugins from being activated.

Backup Plugins

At this time, Pressable doesn’t specifically disallow plugin activation for backup related plugins. If our Customer Success team detects that a backup plugin on your site is causing performance and/or resource contention issues, the backup plugin will be disabled and removed.

Some backup plugins may fail to work on Pressable sites due to how they locate the site root path. Many assume that the PHP constant ABSPATH leads to the site root. While this is common with most WordPress setups, the ABSPATH file path is not the location of the site root. Contact the Customer Success team for further assistance.

CSS/JS Minification Plugins

These plugins can cause sites to slow down or not function properly:

  • bwp-minify

Caching Plugins

These plugins interfere with our own caching systems and can often break the caching we’ve implemented causing your sites to slow down or not function properly:

  • nginx-helper
  • w3-total-cache
  • wp-super-cache
  • wp-fastest-cache

Email Plugins

  • e-mail-broadcasting
  • send-email-from-admin
  • mailit

Other Plugins

  • broken-link-checker (Overwhelms our servers with a very high amount of HTTP requests)

This article is subject to change from time to time and if you ever have questions about these plugins, please don’t hesitate to contact our happiness team.

An Automattic Invention A family of WordPress solutions.